Install Liquidsoap 1.1 on CentOS 6.4

This tutorial gets you liquidsoap 1.1 with MP3 support ONLY on a CentOS 6.4 fully updated system (was not tested on other yum based systems, but feedback is welcome).

The tutorial has not been fully tested yet, it has flaws I bet, I did one install and wrote down everything i could remember, it will be updated over time to make it as perfect as possible, please leave any comments you have.

Install packages

Install Lame

Install AAC+ (libaacplus)

cd /tmp
wget http://217.20.164.161/~tipok/aacplus/libaacplus-2.0.2.tar.gz
tar xvzf libaacplus-*
cd liba[tab]
./autogen.sh –enable-shared
make
make install
(I got lots of errors and I didn’t manage to install it for now, will update once I manage).

Install libmad

NOTICE:

Fix: remove
optimize=$optimize -fforce-mem”
from “configure” and rerun ./configure make make install

Install ocaml-pcre

Install camomile

Setup system for liquidsoap

We need to create a user that is not root (and for security measures, hopefully you’re not logging in as root to your server and maybe you’ve also changed the SSH port…)

Create the directories

Install Liquidsoap

Login as user

 

Create the PACKAGES file with the contents bellow:

Make sure only  these are uncommented or simply just add these

Start the installation

as root

Verify the installation

You should get

NOTICE:
On Error:

do:

  • mustafa420c

    is there an updated tutorial the release i have is 6.5 of centos

    • http://twitter.com/puck Puck

      Should work on 6.5 too. I will test it soon.

  • SimonJC

    With ocaml-pcre I noticed that the version numbers were different. As my 6.5 baulked at the newer version i used the older version (6.2.5). This had no configure file but ran make and make install ok. Also there was no make and make install for camomile but did this anyway! Plus one spelling mistake for the word “configure” for liquidsoap itself. Other than that it works a charm on 6.5. Great guide!

  • Marius

    Currently pcre-ocaml package is not available through your link.

    It has been moved to http://mmottl.github.io/pcre-ocaml/

    After donwloading current version i’ve tried to install it without success.

    “W: Field ‘ocaml_version_ge_3_12′ is not set: Cannot satisfy version constraint on ocaml: >= 3.12 (version: 3.11.2)
    W: Field ‘findlib_version_ge_1_3_1′ is not set: Cannot satisfy version constraint on findlib: >= 1.3.1 (version: 1.2.5)
    E: Findlib version 1.2.5 doesn’t match version constraint >= 1.3.1
    E: OCaml version 3.11.2 doesn’t match version constraint >= 3.12
    E: Failure(“2 configuration errors”)

    Centos 6.5

  • Karol Dziedzic

    –disable-camlp4 it help Centos 6.5